Platinum & Maschine MK3 VST - сдвигаются ноты.

Тема в разделе "Sonar", создана пользователем Kazimir6091, 10 фев 2019 в 17:09.

  1. Kazimir6091

    Kazimir6091 Member

    Регистрация:
    1 дек 2017
    Сообщения:
    32
    Симпатии:
    0
    Пол:
    Мужской
    Всем доброго дня.
    В общем, Maschine standalone работает как часы, ни тормозов, ни багов.
    Подключаю как VST в Сонаре, запускаю проект - все отлично. Играет один в один, как в standalone, если ничего не трогать.
    Но стоит начать переключаться между группами и останавливать/запускать воспроизведение, как мелодические паттерны начинают сдвигаться вниз на один тон. Т.е. нота ре начинает звучать, как до.
    Причем сдвигается та группа, с которой переключаешься, остальные играют, как играли. Но постепенно, по мере переключения между группами, причем ничего в них не трогая и не меняя, так же сдвигаются и остальные.
    Барабасы не затрагиваются, только мелодические партии.
    Подключаю Машину как источник МИДИ к другому VST-синту - та же петрушка.

    Характерная особенность глюка вот в чем - тронул на Машине питчбенд (слайдер), тональность восстанавливается.

    Записал ноту с Машины в Сонар. Вне зависимости от того, сдвинуто ли звучание или нет, в трек пишется нота "ре" (условно... правда, на пару октав выше, но с этим отдельно разберусь).
    Дальше прикол - добиваемся сдвига, начинает звучать "до", причем на самом синте, если нажимать "ре", звучать будет все равно "до". Трогаем питч на Машине - все восстанавливается.
    Короче, сдвиг всегда, на всех инструментах, один и тот же - на тон вниз.

    Куда копать посоветуете?

    Настройки смотреть смысла нет, т.к. изначально, при загрузке проекта, все звучит, как надо. Сдвиг появляется исключительно после манипуляций с группами в Машине - мьютирование, переключение и т.п.

    PS^ Другой DAW на компе нет, ставить ну о-о-о-очень не хотелось бы.
     
  2. Kazimir6091

    Kazimir6091 Member

    Регистрация:
    1 дек 2017
    Сообщения:
    32
    Симпатии:
    0
    Пол:
    Мужской
    Сорри, Машина MK3
     
  3. Elle

    Elle Богиня

    Регистрация:
    14 фев 2006
    Сообщения:
    4.269
    Симпатии:
    3.067
    Пол:
    Женский
    Род занятий:
    Quality Assurance
    Адрес:
    Берлин
    @Kazimir6091, копайте в сторону настроек вашего аппаратного МИДИ-устройства в Сонаре. Скорее всего происходит примерно следующее:
    * по умолчанию MIDI In в машине у каждого саунда настроен на Focus, т.е. подключенные к машине МИДИ-устройства будут управлять только той дорожкой, которая в данный момент выделена (находится в фокусе).
    * меняя группу, вы меняете и фокус на соответствующий саунд из группы
    * по какой-то причине, из сонара на MIDI In в машине приходит Pitch Bend = 0 в абсолютном значении (т.е. -8192)

    Вот и ищите источник - может к сонару подключен ещё один МИДИ-контроллер, который всё время питч-бенд шлёт? Может сам сонар при воспроизведении отправляет некоторый МИДИ "ресет". Может в дорожках сонара питч-бенд явным образом прописан. В общем вариантов уйма.

    С такой проблемой сталкивалась и как-то её решала, но как конкретно уже не помню. Кажется, сталкивалась несколько раз и причины были разные. Один раз выяснилось что У-Хе не умеет нормально работать с ВСТ3, а в ВСТ2 и Дива, и РеПро нормально заработали. В другой раз у меня был зажат питчбенд случайно. Ещё кажется что-то было. Как-то даже во все паттерны в машине прописывала Pitch Wheel на ноль. В общем для начала надо изолировать проблему. А там уже и решение придумаете, скорее всего.
     
  4. Kazimir6091

    Kazimir6091 Member

    Регистрация:
    1 дек 2017
    Сообщения:
    32
    Симпатии:
    0
    Пол:
    Мужской
    Вы, как всегда, бесподобны :)

    Спасибо за направление.
    Машина сейчас одна подключена - кейлаб, битстеппро и прочее МИДИ-добро отключено.
    Подумал вот еще о чем... недавно с АСТ возился (пока Артурия окончательно не обломала с Сонаром). И убей не вспомню, отключил ли я пульты. Надо бы исключить из списка потенциальных причин, а то я там навертел, помнится.

    Настроек Машины в Сонаре, собственно, как таковых, нет.
    Тестировал проблему вообще на новом пустом проект - пишем одну ноту.
    Смущает то, что свежезагруженный проект Машины в ВСТ-режиме нормально работает. Ничто никуда не уплывает.
    Пока группы не трогаешь.
    Т.е. никаких паразитных миди-данных ни в машину ни из машины не передается.

    Завтра попробую побольше статистикy набрать.
    На нативный форум написал, просмотры есть, но пока молчит народ.

    PS^ Попробовать бы ее на другом компе с Сонаром, но таковых в обозримом пространстве не предвидится. Если уж совсем закопаюсь, буду на форуме искать, к кому можно подъехать-попробовать.

    PЫS^ Кошмар, на что приходится жизнь тратить :))
     
    Последнее редактирование: 10 фев 2019 в 20:44
  5. Kazimir6091

    Kazimir6091 Member

    Регистрация:
    1 дек 2017
    Сообщения:
    32
    Симпатии:
    0
    Пол:
    Мужской
    И снова здравствуйте.
    В общем, сломал поначалу голову, жутко трасстроился своему бессилию. Ничего не получалось часа два.
    Все пульты поотключал... съезжает и все тут. не на тон, а на полтора (ну это неважно).
    В режиме контроллера Машины пара ручек сдвинуты были, вернул в нули. Короче, все, до чего дотянулся - все по нулям. Причем можно пару минут гонять проект, пока он не сдвинется.

    Потом сделал вот что.
    Плюнул на группы, потер все нафиг, создал одну группу, записал в ней две дорожки. Инструменты взял нативовские, из фабричной библиотеки. Стал в Машине манипулировать настройками MIDI IN и MIDI OUT во вкладке Sounds. И вот что обнаружил.
    MIDI IN стоял всегда в Default. Ну стоял и стоял, в голову не придет трогать, вроде как. С выходами более менее понятно - None и Host. Нан - работаем в Машине, хост - гоним в Сонар. Сдвигает, зараза. Причем может пару-тройку запусков плей сыграть нормально, на четвертый - сдвиг. Если тронуть питчбенд, восстанавливается и, если не останавливать, так и будет правильно играть до второго пришествия. Остановил/запустил - сдвиг. Бешенство нарастает.
    Решил исключить любые входные данные, поставил MIDI IN в None. И наступило счастье. Сдвиг исчез.
    Погоняю еще, кнчн, но, в любом случае, десять, двадцать раз плей/стоп - сдвига нет.

    В общем, если ставить MIDI IN default/host/focus - имеем сдвиг.
    None - все четко.

    Вроде УРРА, но нормально ли это?
    Не получится ли, подключив клаву в миди ин машины, уже неустраняемый сдвиг от клавы.. пробовать надо. Прикупил тут на досуге кейстеп (большая клавиатура неактуальна сейчас, что-то оброс Артуриями :)), спаяю кабель и буду ее тестить.

    PS^ Еще с октавами разобраться бы. В режиме контроллера Машины с пэдов набираю партию (можно и в обычном режиме, но с контроллера исключаем внутреннюю машинную составляющую, оставляя только миди-сообщения, кст, очень наглядно и удобно). Так вот 5 страница, базовая нота С3. Жму. В Сонаре четко прописывается .... С5.
    Это, кнчн, не проблема-проблема, но все же непонятно. Может, VST с характером или еще что.
     
  6. Kazimir6091

    Kazimir6091 Member

    Регистрация:
    1 дек 2017
    Сообщения:
    32
    Симпатии:
    0
    Пол:
    Мужской
    Кст, небольшой офф.. пока не могу понять внутреннюю организацию Машино-комплекса. Например, как она работает с синтами.
    В DAW, чтобы взять несколько тембров с одного синта, нужно столько же дорог и этих синтов открыть.
    В Машине беру три-четыре дороги, на все вешаю тембры из FM8. С каждой дороги открываю синт - на мониторе открывается именно этот тембр. В FM8 пречудесный степ-секвенсор. Так вот в Машине можно буквально на лету строить на FM8 (да и на чем угодно) умопомрачительные динамические сложные многодорожечные мультиразмерные секвенции, хочешь, развивай берлинский олдскул, хочешь, экспериментируй с хаотическими структурами... А ежели разбавить это все реакторовским Spiral и басовой линией на Репро-1 - похлеще любых искусственных стимуляторов будет. Потрясающая игрушка.
    Деньги музыкой не зарабатываю, разве что для своих корпоративных роликов пишу треки (сам руководитель :)), основная потребность - прикоснуться к давним несбыточных мечтам юности. А сегодняшние железки и софт с лихвой перекрывают даже самые смелые и абсолютно неисполнимые в свое время желания. Так что просто балдею часами и жизнь наполняется смыслом и нереальным удовольствием.

    Непонятно также, почему 99,99999% всех видосов по Машине - какие-то хип-хоп барабасы да диджейские фишки , даже встроенные проекты - не за что зацепиться, сплошная инкубаторская банальщина. А ведь Машина куда продвинутей тех же битстеппро, причем в любом их количестве :)

    Стою в очереди на Cirklon, но, помимо сомнений в финише данного мероприятия, уже есть сомнения в остром желании им обладать. Машина + Битстеппро + DAW// что еще надо, чтобы (варианты..)

    ====
    Сорри за много букв. Под впечатлением от получившегося решения (кст, ?)проблемы и в предвкушении...
     
    Последнее редактирование: 11 фев 2019 в 16:29
  7. Elle

    Elle Богиня

    Регистрация:
    14 фев 2006
    Сообщения:
    4.269
    Симпатии:
    3.067
    Пол:
    Женский
    Род занятий:
    Quality Assurance
    Адрес:
    Берлин
    ну я ж говорю из сонара по МИДИ приходит неправильный питч-бенд. Надо только источник его определить. Я сейчас вспоминаю, я какой-то параметр в настройках сонара меняла как раз для этого. Не помню навскидку какой. Буду дома с кейком перед глазами - попробую вспомнить. Но там что-то с МИДИ событиями при нажатии воспроизведения.
    --- добавлено 11 фев 2019 в 16:31 ---
    кажется какую-то из этих галок надо было отключить
    upload_2019-2-11_17-31-6.png
     
    Kazimir6091 нравится это.

Поделиться этой страницей