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What’s New in Pro Tools 2023.9

New Features and Enhancements
Pro Tools® software version 2023.9 provides the following new features and enhancements:

• Pro Tools Sketch™

• App for iOS on iPad

• Sketch window in Pro Tools

• Miscellaneous new features and improvements

• Save Copy In with Selected Timeline Range option

• Reordering plug-ins by drag and drop

• Width-changing plug-ins organized in sub-menu

• Track Marker improvements

• New immersive surround format path orders in I/O Setup

• New Path Order listings added to the Input page of the I/O Setup

• New Disable Slewing While Looping option

• Activate Pro Tools Power Scheme option in the Playback Engine (Windows only)

System Requirements and Compatibility Information
Avid can only assure compatibility and provide support for hardware and software it has tested and approved. 

For complete system requirements and a list of qualified computers, operating systems, hard drives, and third-party devices, visit:

www.avid.com/compatibility

Conventions Used in This Guide
Pro Tools documentation uses the following conventions to indicate menu choices, keyboard commands, and mouse commands:
:

The names of Commands, Options, and Settings that appear on-screen are in a different font.

The following symbols are used to highlight important information:

Convention Action

File > Save Choose Save from the File menu

Control+N Hold down the Control key and press the N key

Control-click Hold down the Control key and click the mouse button

Right-click Click with the right mouse button

User Tips are helpful hints for getting the most from your Pro Tools system.

Important Notices include information that could affect your Pro Tools project data or the performance of your Pro Tools system.

Shortcuts show you useful keyboard or mouse shortcuts.

Cross References point to related sections in this guide and other Avid documentation.
 What’s New in Pro Tools 2023.9 1
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How to Use this PDF Guide
This PDF provides the following useful features:

• The Bookmarks on the left serve as a continuously visible table of contents. Click on a subject heading to jump to that page.

• Click a + symbol to expand that heading to show subheadings. Click the – symbol to collapse a subheading.

• The Table of Contents provides active links to their pages. Select the hand cursor, allow it to hover over the heading until it turns 
into a finger. Then click to locate to that subject and page.

• All cross references in blue are active links. Click to follow the reference.

• Select Find from the Edit menu to search for a subject.

• When viewing this PDF on an iPad, it is recommended that you open the file using iBooks to take advantage of active links within 
the document. When viewing the PDF in Safari, touch the screen, then touch Open in “iBooks”.

Resources
The Avid website (www.avid.com) is your best online source for information to help you get the most out of your Avid system. 

Account Activation and Product Registration
Activate your product to access downloads in your Avid account (or quickly create an account if you do not have one). Register your 
purchase online, download software, updates, documentation, and other resources.

www.avid.com/account

Support and Downloads
Contact Avid Customer Success (technical support), download software updates and the latest online manuals, browse the Compatibil-
ity documents for system requirements, search the online Knowledge Base or join the worldwide Avid user community on the User Con-
ference.

www.avid.com/learn-and-support

Training and Education
Study on your own using courses available online, find out how you can learn in a classroom setting at an Avid-certified training center, 
or view video tutorials and webinars.

www.avid.com/learning

Videos and Tutorials
Visit the Avid YouTube channel to find playlists and videos that show how to use and learn Pro Tools.

Avid YouTube Channel (all playlists and videos)

Pro Tools Quick Tips (playlist for the Pro Tools Quick Reference Guide, available from the Dashboard)

Products and Developers
Learn about Avid products, download demo software, or learn about our Development Partners and their plug-ins, applications, and 
hardware.

www.avid.com/products
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Pro Tools Sketch

Pro Tools Sketch App
Pro Tools Sketch™ is a free application for iOS on iPad that lets you add, create, edit, arrange, and play back MIDI and audio clips. 
Pro Tools® provides the Sketch window (available in all tiers), which provides the same functionality as the Sketch app right in 
Pro Tools. Sketches can be created in either the app or in Pro Tools and can be shared between them. Audio for Sketches on iPad 
is always stereo, 24-bit, 48 kHz. In Pro Tools, Sketches conform to the bit depth and sample rate of the Playback Engine.

Pro Tools Sketch is essentially a clip launching application (both audio and MIDI). The ability to mix Audio and MIDI clips, audio 
effects, and virtual instruments in a non-linear environment, makes Pro Tools Sketch a flexible centerpiece to your creative process. 
Pro Tools Sketch lets you experiment with different sounds and musical ideas in context with each other without having to focus 
immediately on the arrangement or linear sequencing.

Pro Tools Sketch Window
The Sketch window in Pro Tools mirrors the functionality of the Pro Tools Sketch app. However, there are some unique controls 
and behaviors with the Sketch window in Pro Tools.

For more information, see the Using Pro Tools Sketch.pdf. Where that guide tells you to “tap,” in the Sketch window you will click; 
and where you would double-tap in the app, you will right-click in the Pro Tools Sketch window (but with some exceptions).

Sketch window in Pro Tools
 Pro Tools Sketch 3



Creating a Sketch in Pro Tools
Pro Tools lets you create and open sessions, projects, and now Sketches. Sketches can be created and opened in Pro Tools inde-
pendently of sessions and projects. You can also “pin” a Sketch to a session.

To create a new Sketch in Pro Tools:

1 Launch Pro Tools.

2 Choose File > New (or File > Dashboard).

3 Click Sketch.

4 Type the Name you want for your Sketch (optional).

5 Click Create.

Sketches created in Pro Tools use the Playback Engine settings for bit depth and sample rate. When sharing Sketch files between 
Pro Tools and mobile, bit depth and sample rate conversion is managed in the background.

Opening and Viewing a Sketch in Pro Tools
You can open a Sketch in Pro Tools whether a session is open or not.

To open a Sketch in Pro Tools:

1 Launch Pro Tools.

2 Choose File > Open > Sketch.

Sketches are not fully supported with projects. They cannot be shared in a collaboration, but they can be part of a project locally.

Dashboard, new Sketch

To open a Sketch, press Command+Option+Control+O (Mac) or Control+Alt+Start+O (Windows)
 Pro Tools Sketch 4



3 Navigate to and select the Sketch you want to open.

4 Click Open.

Sketch Window Open with a Pro Tools Session

To bring the Sketch window to the front when you have both a Sketch and a session open at the same time, do one of the following:

 Choose Window > Sketch to Front.

 Press Command+Options+Control+= (Mac) or Control+Alt+Start+= (Windows).

Saving a Sketch in Pro Tools

To save a Sketch in Pro Tools:

 With the Sketch window in the foreground, do one of the following:

• Choose File > Save Sketch.

• Press Command+S (Mac) or Control+S (Windows).

To save a Sketch as a new Sketch in Pro Tools:

 With the Sketch window in the foreground, do one of the following:

• Choose File > Save Sketch As.

• Press Command+Control+S (Mac) or Control+Start+S (Windows).

To save a copy of Sketch in Pro Tools:

1 Ensure that the Sketch window is in the foreground.

2 Choose File > Save Sketch Copy In.

3 In the resulting dialog, navigate to where you want to save the copy of the Sketch.

4 Type a name for the copy and click Save.

Pro Tools Sketch Window Controls

Audio Output (Monitoring) Select the monitor output for the Sketch window. This can be any stereo path defined in the Pro Tools 
I/O Setup (stereo only).

Audio Input Select the audio input for recording audio clips in the Sketch window. This can be any stereo path defined in the Pro 
Tools I/O Setup (stereo only).

MIDI In Select the MIDI input device and channel for recording MIDI clips in the Sketch window.

Volume This master volume control (vol) lets you adjust the monitoring volume for the Sketch window.

Mute Mute lets you mute the output signal of the Sketch window.

Level Meter This stereo segmented level meter displays volume levels and provides clip indicators for the Sketch audio output.

Sketch window controls in Pro Tools

Audio Out Audio In

MIDI In

Volume Mute Pin to Session

Level Meter
 Pro Tools Sketch 5



Pin to Session If you have the Sketch window and a Pro Tools session open at the same time, you can pin the Sketch window to 
the session. This means that whenever you open that session while the Sketch remains pinned to it, the Sketch window opens with 
that particular Sketch document. Note that a Sketch can be pinned to multiple sessions.

Sketch Window Toolbar

Media Browser

Sound Library

Pro Tools Sketch includes a collection of sounds and MIDI, including audio loops and one shots, and MIDI patterns.

Loops

The audio loops included with Pro Tools Sketch are available in the Loops directory of the Sound Library tab.

MIDI

The MIDI sequences included with Pro Tools Sketch are available in the MIDI directory of the Sound Library tab.

Browse

Click the Browse tab to navigate your system directories for audio and MIDI files. You can drag and drop any audio or MIDI file 
to Pro Tools Sketch from any accessible location.

Undo/Redo
Click the Undo icon to undo your last edit in the Sketch. Click the Redo icon to redo the last undone edit in the Sketch.

Sync
When Sync is enabled, the Sketch window plays in the context of Pro Tools (like with Elastic Audio in the Workspace browser). 
The Sketch plays back following the Pro Tools tempo, and the Scene Arranger and Pro Tools timeline are synced. The Sketch file 
returns to its original tempo when Sync is disabled (even if you saved when it was synced, it will not be overwritten with the 
Pro Tools session tempo).

Also, when Sync is enabled, regardless of what tempo a Sketch file was created in, media that is dragged from the Sketch window 
to the Pro Tools timeline is time-stretched to fit the Pro Tools session tempo. When Sync is disabled, media dragged from the 
Sketch window into Pro Tools retains its original duration.

Sketch Window Toolbar

Media browser

Undo/Redo

Input Mon

Pause/
Counter

Play

Tempo

Time Signature
Launch Timing

Preferences

MetronomeReturn to Zero

Sync
 Pro Tools Sketch 6



Input Monitoring
Click to enable (or disable) audio input monitoring (audio tracks only).

Counter
Displays the current playback location. Click to open the Transport Settings where you can change the location of play start.

Pause/Return to Zero
Click the Pause icon once to pause playback. Click it again to return to the beginning of the Sketch.

Play
Click the Play icon to start playback.

Tempo
Displays the Sketch tempo. Click to open Sketch Settings where you can change the tempo.

Time Signature (Meter)
Displays the Sketch meter. Click to open Sketch Settings where you can change the meter.

Launch Timing (Launch Quantize)
Set the Launch Timing (LT) for the start of clip playback. This is when a clip starts playback in a Scene or Scene Arrangement.

Metronome
Click to play the Metronome click. Click again to stop the Metronome.

Preferences
Click to open the Sketch Window Preferences (not the Pro Tools Preferences).

Selecting the rhythmic value for Launch Timing
 Pro Tools Sketch 7



Clips
Drag and drop to an empty Clip cell to add a clip to an existing track or to an empty space to create a new track (an Instrument track 
for MIDI clips or an audio track for audio clips) with the new clip in the first cell. You can also drag and drop clips between the 
Pro Tools Sketch window and the Pro Tools Edit window, the Clips List, and Workspace browsers. Additionally, Scenes can be 
dragged and dropped from the Sketch window to the Pro Tools timeline in the Edit window.

Adding Clips to a Sketch

To add clips to a Sketch, do one of the following:

 Drag and drop from Media browser to a cell.

 Drag and drop from a Pro Tools Workspace browser to a cell.

 Drag and drop from the Finder (Mac) or Windows Explorer (Windows) to a cell.

 If you have a session open, drag and drop from the session Clips List to a cell on a track.

You can only drag single interleaved stereo clips from sessions to the Sketch window. Clips with fades can be imported, but any 
fades are removed. Clip groups are not supported.

You can drag MIDI clips from a session to an Instrument track in the Sketch window and see the MIDI notes. However, when 
dragging and dropping MIDI clips from the Sketch window into a session, they can you can only be dragged to an audio track 
in a session and are converted to audio clips.

Dragging and dropping from Media browser to a clip cell on an audio track
 Pro Tools Sketch 8



Playing Back Individual Clips
You can play back individual clips in your Sketch.

To play back any individual clip, do one of the following:

 Click the Play icon on the clip you want.

 Click the Play icon in the Editor for the selected clip.

Recording Clips
When you record into an empty clip cell, audio or MIDI, you can do long form recording. When recording into an empty clip, the 
subsequent recording is of a fixed length determined by the current clip boundaries. With MIDI, recording into an existing clip re-
sults in MIDI Merge recording.

Recording Audio Clips

The Pro Tools Sketch window lets you record audio clips using the selected stereo audio input (available inputs are defined in the 
Pro Tools I/O Setup).

To record audio clips:

1 Select the audio input path.

2 If desired, click Input Monitor to hear your audio source during recording.

3 Click Track Record enable on an audio track.

4 Click Clip Record on the clip cell where you want to record audio. 

Recording starts immediately. However, if you are at a counter position between Launch Timing points, then recording starts at the 
next timing point.

Record into an empty clip cell to record for an indefinite length. Record into an existing empty clip with defined boundaries to re-
cord for the duration of this clip. You cannot record into and overwrite audio in an existing clip.

5 When you are finished recording, click Stop in the Sketch Window toolbar.

You can view the audio you recorded in the Audio Clip Editor.

Recording an audio clip

Track Record enable Clip Record
 Pro Tools Sketch 9



Recording MIDI Clips

Pro Tools Sketch lets you record MIDI clips using the selected MIDI input device.

To record MIDI clips:

1 Select the MIDI device for MIDI Input.

2 Click Track Record enable on an Instrument track.

3 Click Clip Record on the clip cell where you want to record MIDI. Recording starts immediately. However, if you are at a 
counter position between Launch Timing points, then recording starts at the next timing point.

Record into an empty clip cell to record for an indefinite length. Record into an existing MIDI clip to record for the duration of the 
existing clip—recorded MIDI merges with the existing MIDI in the clip.

4 Play your MIDI controller or playback MIDI from a Pro Tools MIDI or Instrument track. (You can also click keys on the 
on-screen keyboard in the Editor view or the on-screen keyboard of a Virtual Instrument in Track view).

5 When you are finished recording, click Stop in the Sketch Window toolbar.

You can view the MIDI you recorded in the MIDI Clip Editor.

Duplicate Clip

To duplicate a clip:

 Right-click the clip and choose Duplicate.

The clip is duplicated in the next empty clip cell on the track.

Remove Clip

To remove a clip:

 Right-click the clip and choose Remove.

The clip is removed from the track.

Recording a MIDI clip

Track Record enable Clip Record 
 Pro Tools Sketch 10



Open in Editor

To open a clip in the Editor:

 Right-click the clip and choose Open in Editor.

The audio or MIDI clip opens in the Editor tab. You can also double-click any clip to open it in the Editor tab.

Clip Properties

To edit the properties for a clip:

1 Right-click the clip and choose Properties.

2 Make the changes you want in the Clip Properties window.

3 Click OK.

Name Type the name you want for the clip.

Type Displays the Clip Type: AUDIO or MIDI.

Source BPM Displays the BPM for the source clip. Click Edit to change.

Color Enable (or disable) to show the selected clip color. Click in the color palette to select the color you want for the clip.

Loop Enable (or disable) to loop the clip on playback. Clips with loop disabled act as “one shots.”

Scenes and Arrangement
Clips on tracks can be played back all together in a Scene. A Scene is a row of clips in the Clip Launcher. Scenes can be ordered 
in an Arrangement, and each Scene can be set to repeat playback by a specified number of time. Fore example, in an Arrangement 
you can have Scene 1 play four times and then move to playing back Scene 5 two times, and so on. Scenes do can be ordered in an 
Arrangement however you want: Scene 5 x2, Scene 3 x4, Scene 8 x1, and so on.

Scenes
Scenes are rows of clips that can be played back all together.

You should only change the Source BPM if you know it should be different than what is displayed.

Scene Play and Stop All icons

Play Scene

Stop All
 Pro Tools Sketch 11



To play back a Scene:

 Click the Play icon for the Scene.

To stop playback of a Scene:

 Click the Stop All icon at the bottom of the Scenes column. This stops playback of the Scene and any other clips that may be 
playing back on other tracks (and in other Scenes).

To duplicate a Scene:

 Right-click the Scene you want in the left-hand column and choose Duplicate.

To delete a Scene:

 Right-click the Scene you want in the left-hand column and choose Delete.

To change Scene Properties:

1 Right-click the Scene you want in the left-hand column and choose Properties.

2 Type a new Name for the Scene if desired.

3 Click Color to select a color for the Scene and then click the color you want in the color palette.

4 Click OK.

To add a new Scene above another Scene:

 Right-click the Scene you want in the left-hand column and choose New Scene Above.

To add a new Scene below another Scene:

 Right-click the Scene you want in the left-hand column and choose New Scene Below.

To create a new Scene from clips playing on different tracks:

1 Start playback of clips on different tracks and Scenes that you want to duplicate on the same tracks, but into a new Scene.

1 Right-click any Scene in the left-hand column and choose Create Scene from Playing.

Scene Properties
 Pro Tools Sketch 12



Dragging a Scene into a Session

You can drag and drop any Scene from the Sketch window to the Timeline in the Edit window of an open session. Doing so results 
in new tracks matching those in the Sketch being created in the session with media beginning at the Timeline location where you 
dropped the Scene. Scenes cannot be dropped in the Tracks List.

Dragging a Scene from the Sketch window onto Timeline in Edit window

Scene dropped from Sketch window onto Timeline in Edit window
 Pro Tools Sketch 13



Arrangement
The Pro Tools Sketch window lets you create an Arrangement of different Scenes that you can set up like a song. You can export 
the Arrangement as a new audio file or drag and drop it into an open Pro Tools session.

To add a Scene to the Arrangement:

 Drag and drop a Scene from the left-most column up into the Arrangement.

To reorder Scenes in the Arrangement:

 In the Arrangement, drag and drop a Scene to a new location in the Arrangement,

To repeat a Scene in the Arrangement:

1 Click the Scene Multiplier to the right of the Scene in the Arrangement.

2 Click + to increase the number of times that you want the Scene to repeat during playback of the Arrangement, or click – to de-
crease the number of times that you want the Scene to repeat during playback of the Arrangement. 64 is the maximum number 
of repeats for a Scene in the Arrangement.

3 Click Close.

To remove a Scene from the Arrangement:

Right-click the Scene in the Arrangement that you want to remove and choose Remove Scene.

To export the current Arrangement from your Sketch as a new audio file:

1 Click the Arrangement menu icon and choose Export Arrangement.

2 Navigate to the location where you want to save your Arrangement.

3 Type a name for the Arrangement.

4 Click Export.

To clear all Scenes from the Arrangement:

 Click the Arrangement menu icon and choose Clear All.

Adding a Scene to the Arrangement
 Pro Tools Sketch 14



Dragging the Arrangement into a Session

You can drag and drop an Arrangement from the Sketch window to the Timeline in the Edit window of an open session. Doing so 
results in new tracks matching those in the Sketch being created in the session with media beginning at the Timeline location where 
you dropped the Arrangement. The Arrangement cannot be dropped in the Tracks List.

Tracks
Tracks in the Sketch window consist of columns of MIDI or audio clips. Each track provides its own mixer controls and real-time 
effects processing for all clips on the track. Audio and MIDI tracks both have three effects inserts. MIDI tracks use virtual instru-
ments (PlayCell and SynthCell) for MIDI playback on the first insert on the track.

Arrangement dragged from Sketch window onto Timeline in Edit window.

Track tab: audio track
 Pro Tools Sketch 15



Editor
You can edit selected audio and MIDI clips in the Sketch window. You can trim the clip boundaries, enable or disable looping, edit 
audio or MIDI notes, and so on.

Track tab: Instrument track

Editor tab: audio clip
 Pro Tools Sketch 16



Zooming in the Sketch Window Editor

To zoom out or in the Sketch Window Editor, do one of the following:

 Press Command+[ or Command+] (Mac), or Control+[ or Control+] (Windows).

 With Key Command Focus enabled, press R or T.

 Command-scroll up or down (Mac), or Control-scroll up or down (Windows).

Adding or Deleting Notes in the MIDI Editor

To add MIDI notes in the MIDI Editor:

 Double-click in blank space in the Clip Editor to add a MIDI note there.

To delete MIDI notes in the MIDI Editor:

 Double-click MIDI notes in the Clip Editor.

Editor tab: MIDI clip
 Pro Tools Sketch 17



Mixer
The Mixer tab lets you mix tracks, including plug-in effects, global effects sends, panning, levels, and solo and mute.

Global FX
The Global FX tab lets you adjust settings for Delay and Reverb, which are fed by the effects sends on tracks in the Mixer tab.

Mixer tab

Global FX tab
 Pro Tools Sketch 18



Preferences
The Sketch Window Preferences are distinct from the Pro Tools Preferences. They are a limited number of settings just for 
Sketches and the Sketch window.

To open the Sketch Window Preferences:

 Click the Preferences icon (the Gear icon) in the upper-right corner of the Sketch window. 

Documentation Click to access the Using Pro Tools Sketch Guide.pdf online. The functionality of the Sketch window is nearly 
identical to using the Sketch app on iPad. In most cases, where the guide says to tap in the app, click in the window, and where it 
says to double tap, right-click.

About Click to view the version of Pro Tools Sketch that you are running. In the resulting window, click Close to close the About 
window.

Close Click to close the Preferences window.

Sketch Window Preferences
 Pro Tools Sketch 19



Miscellaneous Features and Improvements

Export Session Range
Pro Tools lets you save a copy of a timeline range of a session. This is useful for splitting a session into smaller pieces.

When saving a copy of a timeline range, only clips on the timeline within the selection are included in the export. If a clip on a main 
or alternate playlist spans the edge of the selection, the exported session includes a trimmed version of the clip. The source session 
is unaffected. Note that files themselves are not truncated. The entire file is still copied, but only the clip is trimmed. Exporting a 
timeline range can be used in conjunction with both the Main Playlist Only and Selected Tracks Only options to further refine the 
export and limit what is copied. The session start is not affected.

Anchor breakpoints are always written at the start and end of the selection for all automation playlists that contain one or more writ-
ten breakpoints. This prevents any unwanted automation ramps.

Optionally, when the Anchor All Automation Playlists option is enabled, anchor breakpoints are added to automation playlists that 
do not have any additional written breakpoints. This ensures that the values are anchored if the session is imported into another ses-
sion, and that only automation within the specific imported range is affected.

Anchor breakpoints are not written to Plug-in automation play-lists unless their controls are already automation-enabled and have 
one or more written breakpoints.

To save a copy of a timeline range of a session:

1 Make a timeline range selection in the open session.

2 Choose File > Save Copy In.

3 Select Selected Timeline Range Only.

4 Click OK.

5 Navigate to the location where you want to save the new session.

Save Copy In dialog, Selected Timeline Range Only option
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6 Type a name for the new session.

7 Click Save.

Plug-in Insert Reordering by Drag and Drop
Pro Tools lets you drag and drop plug-ins from one insert to between inserts. This results in reordering of plug-in inserts on the tar-
get track, moving any plug-ins below it down to the next slot below (assuming one is available). A yellow line indicates where the 
plug-in will be inserted.

Width-Changing Plug-ins Organized in Sub-menu
The Inserts menu has been improved by simplifying the way in which different channel widths (formats) of a plug-in are listed. 
Whenever a plug-in supports four or more channel widths, the different channel width options are provided in a sub-menu for that 
plug-in. This helps manage clutter in the Plug-in Inserts menu. Note that when the Organize Plug-In Menus By Flat List option is 
enabled in the Preferences, plug-ins do not appear in a submenu. If widths are hidden from the Show/Hide menu in the new tracks 
dialog or new paths dialog in IO setup, those widths for width changing plug-in are also hidden from the drop-down menus as well 
as the search results for inserts.

Track Marker and Memory Location Improvements
Key commands have been added to make it easier to navigate to different marker lanes, as well as the Marker ruler.

Key Commands for Selecting Marker Lanes

To move the Edit selection to the previous Marker Lane, do one of the following:

 Choose Edit > Selection > Move Edit Selection to Previous Marker Zone.

 Press Command+Option+Control+P (Mac) or Control+Alt+Start+P (Windows).

To move the Edit selection to the next Marker Lane, do one of the following:

 Choose Edit > Selection > Move Edit Selection to Next Marker Zone.

 Press Command+Option+Control+; (Mac) or Control+Alt+Start+; (Windows).

To extend the Edit selection to the previous Marker Lane, do one of the following:

 Choose Edit > Selection > Extend Edit Selection to Previous Marker Zone.

 Press Command+Option+Control+Shift+P (Mac) or Control+Alt+Start+Shift+P (Windows).

To extend the Edit selection to the next Marker Lane, do one of the following:

 Choose Edit > Selection > Extend Edit Selection to Next Marker Zone.

 Press Command+Option+Control+Shift+; (Mac) or Control+Alt+Start+Shift+; (Windows).

Dragging and dropping a plug-in between inserts

A red line appears if you cannot insert the plug-in between inserts either because there is no free insert or it is not allowed 
because of routing issues.
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To remove the top-most selected view, including explicitly selected Marker lanes (selected either using mouse or keyboard):

 Press Control+Option+P (Mac) or Start+Alt+P (Windows).

To remove the top-most selected view, including explicitly selected Marker lanes (selected either using mouse or keyboard):

 Press Control+Option+; (Mac) or Start+Alt+; (Windows).

Marker Merge Command Added to the Edit Menu
Edit > Past Special > Merge Markers has been added to the Edit menu. Previously, the Merge Markers command was only avail-
able using the following key commands: press Option+V (Mac) or Alt+V (Windows). This acts as a standard paste command and 
is available when something is in the clip board. The only difference is the behavior when markers are pasted: it merges markers 
instead of overwriting them.

Updated Key Modifier for Assigning Marker Color
(macOS Only)

On macOS, Option+1–8 has been changed to Control+1–8 for marker color selection in the New and Edit Memory Location dia-
logs.

Update Position and Update Selection
When editing an existing Memory Location you can use the Update Position or Update Selection settings to move a Marker or 
Selection to the current playhead location. These settings are only available in the Edit Memory Location window, and are useful 
when you need to change the marker location or the bounds of the selection stored in a Memory Location.

To use Update Position or Update Selection: 

1 Do one of the following:

• For updating markers, make a new timeline insertion.

• For updating selections, make a new edit selection.

2 In the Memory Locations window, Control-click (Mac) or Start-click (Windows) the Marker Memory Location that you want 
to redefine. The Edit Memory Location window appears. You can also Command-click (Mac) or Start-click (Windows) a Mem-
ory Location in the Markers ruler.

3 Enable the Update Position (for a Marker) or Update Selection (for a selection) setting, then click OK. When updating a marker, 
it moves to the current playhead location.

Edit > Paste Special > Merge has been updated to Edit > Paste Special > Merge MIDI,
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Update Position and Update Selection are global settings (their state persists when opening new sessions). 

Edit Memory Location: Update Selection option

Edit Memory Location: Update Position option
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Streamlined Default Path Format Listings
All LFE and Non-LFE formats are now combined into a single listing in the I/O Setup that controls both variations of the format 
as follows:

• Stereo

• LCR

• 5.x

• 5.x.2

• 5.x.4

• 7.x

• 7.x.2

• 7.x.4

• 7.x.6

• 9.x.4

• 9.x.6

New Path Order Listings Added to I/O Setup Input Page
New Path Order listings have been added to the Input page of the I/O Setup to make it easier to create paths that align with monitor 
returns from the Dolby Atmos Renderer.

New Video Slewing Option
Pro Tools 2023.6 introduced the ability to disable slewing with video playback. With Pro Tools 2023.9, a new option has been in-
troduced to disable slewing only during looping playback. Slewing helps audio and video to stay in sync when there is no common 
clock reference between audio and video hardware. However, it can be problematic in certain circumstances, such as with loop 
playback. This option lets you keep longer playback passes in sync, while maintaining performance during loop playback.

To set the Video Slewing preference:

1 Choose Setup > Preferences > Operation.

2 In the Video section, select the desired Slewing option:

Enabled Slewing is always enabled.

Disabled While Looping Slewing is disabled only during looping playback.

Disabled Always Slewing is always disabled.
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3 Click OK.

Activate Pro Tools Power Scheme Option
(Windows Only)

The Playback Engine provides an Activate Pro Tools Power Scheme option (Windows only) that when enabled optimizes 
Pro Tools performance, but requires more power (Windows System Power Management).

Operation Preferences, Video settings

Playback Engine, Activate Pro Tools Power Scheme option
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For technical support go to
www.avid.com/support
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