Arranger track

Overview

The Arranger track is an arrangement tool that provides several workflow benefits:

» Easily rearrange sections of the entire project as one unit instead of moving individual clips. For example, instantly swap the
positions of the first and second chorus for all tracks, or copy the first verse in order to double its duration (see “Arranger track
drag operations” on page 289).

» Experiment with different song structures in a non-destructive and non-linear manner. For example, does your song work best in
AABA, ABAB, or ABAC song form? Define time range sections and sequence them in any order without destructively moving any
clip data. You can even save multiple arrangements within each project (see “Creating arrangements” on page 291).

» Create a color coded overview of the song structure, and use the Arranger Inspector to quickly navigate around the project and
jump to song sections (see “Navigating by Arranger sections” on page 294).

» Create arbitrary song sections anywhere on the project timeline, then later string them together for seamless playback (see
“Defining sections of your song” on page 283 and “Creating arrangements” on page 291).

» Sections provide an additional way to perform time based selections and edits of the project.

» Create an unlimited number of arrangements per project, which can all be exported simultaneously (see “Exporting
arrangements” on page 295).

Arranger functionality is distributed across two views:
» Arranger track (see “Arranger track” on page 277)

» Arranger Inspector (see “Arranger Inspector” on page 278)

Figure 766. Arranger track.
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An arrangement is comprised of Sections, each spanning a unique time range. Other section properties include name and color, to
clearly delineate regions of time and track content by musical function.
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Important: By default, clicking an Arranger section also selects underlying track events. Clicking again deselects track events,
while retaining selection of the section. This behavior allows you to easily determine whether or not track events are included in
section edit operations. Note that the selection highlight in the Clips pane indicates selected track events.

To disable automatic selection of track events when selecting sections, right-click in the Arranger track timeline and disable Select
Events with Sections.

Tip: You can prevent data on individual tracks from being selected when you select Arranger sections. For details, see Arranger
Exclude.

Basic workflow

1.

Create and edit sections either within the Arranger Inspector or Arranger track timeline (see “Defining sections of your song” on
page 283).

Move, add, delete, trim and reorder sections (see “Editing sections” on page 286).

[Optional] Create arrangements (see “Creating arrangements” on page 291):
a) Create alternate orders of sections, called arrangements, without affecting track events.
b) Arrangement sections can be edited and previewed independently of project sections.

c) An arrangement can subsequently be rendered to the project timeline and/or exported (see “Exporting arrangements” on
page 295).

See:

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283

“Editing sections” on page 286

“Creating arrangements” on page 291

“Navigating by Arranger sections” on page 294

“Exporting arrangements” on page 295
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Arranger track

To show or hide the Arranger track, click the Track view View menu and choose Arranger Show/Hide, or press A.

To resize the Arranger track, drag the splitter bar between the Arranger pane and the Track pane to change its height.

Figure 767. Drag the splitter bar vertically to resize the Arranger track.
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The Arranger track is empty until you define one or more sections (see “Defining sections of your song” on page 283).

Arranger timeline

The Arranger track timeline shows all defined sections. You can drag to create and rearrange sections, then freely move them along

the timeline.

Any changes in the Arranger timeline are immediately reflected in the Arranger Inspector’s Sections list, and vice versa.

Tip: To zoom the Clips pane so it shows the full width of a section plus a small portion of adjacent sections, hold down the SHIFT key

and double-click a section. Press ALT+Z to return to the previous zoom level.

See:

“Arranger track” on page 275

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283
“Editing sections” on page 286

“Creating arrangements” on page 291
“Navigating by Arranger sections” on page 294
“Exporting arrangements” on page 295
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Arranger Inspector

The Arranger Inspector manages a list of project sections, and facilitates quick reordering of sections without having to drag or zoom
horizontally within the Clips pane.

To show/hide the Arranger Inspector

To show/hide the Arranger Inspector, do one of the following:

» Click the Show/Hide Arranger button at the top of the Inspector pane
» Double-click a section in the Arranger track timeline
» Press ALT+SHIFT+I

The Arranger track will also be shown if it is hidden.

Figure 768. Inspector header.
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Sections

Sections are the building blocks that make up the song. Each section defines a time range in the project, such as Intro, Verse,
Chorus, etc. An arrangement is an ordered set of sections. You can sort the sections in any order to define the playback order. To do
S0, drag the sections from the Sections area down to the Arrangements area.

The Sections area lists all the arranger sections defined in the project’s timeline, from which a custom arrangement can be built.
The order of the sections reflect the order in which they appear in the timeline.

The Sections list provides an additional way to edit time based selections of the project. Any operation performed in the Sections
list is immediately reflected in the project/timeline, and vice versa.

To copy all sections to the current arrangement, click the Add All Sections to Arrangement button E If one or more sections are
selected, only the selected sections will be copied.

Add Section button

The Add Section button inserts a new section.
» The new section duration is inherited from the last clicked section, or defaults to 1 measure.
» If no sections are selected, the new section is added at the end.

) If at least one section is selected, the new section is added at the beginning of the selection, and downstream sections move to
make room. Any selected track events also move.

See also:
“Defining sections of your song” on page 283
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Arrangements

Figure 770. Arranger Inspector.
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The Arrangements area allows you to sequence sections in a non-linear manner without destructively moving any clip data,
regardless of which order they appear in the project’s timeline.

The Sections list is a collection of project sections from which an arrangement can be built. To create an arrangement, drag sections
from the Sections list or from the Arranger track. Any section can appear multiple times within an arrangement (or not at all).

To move sections in the list, drag them up or down.

To play the current arrangement, click the Preview button n or press ALT+SPACEBAR (see “To preview an arrangement” on page
292). The Arrangements list shows the order in which the sections are played back, from top to bottom.

To (destructively) render the current arrangement to the project’s timeline, click the Commit Arrangement to Project button
(see “To commit an arrangement” on page 293).

o Note: Operations performed in the Arrangements section have no effect on the linear project structure until you click the

Commit Arrangement to Project button E“' at which time the Arranger track timeline and the Sections list in the Arranger
Inspector inherit the structure of the arrangement.

Add All Sections to Arrangement button

The Add All Sections to Arrangement button copies all sections to the current arrangement.

If one or more sections are selected, only the selected sections will be copied.
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Arrangement menu
The Arrangements menu lets you create, select, duplicate, rename, and delete arrangements.

Figure 771. Arrangements menu.
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See also:

“To create a new arrangement” on page 291
“To delete an arrangement” on page 292
“To rename an arrangement” on page 292

“To duplicate an arrangement” on page 292

Preview button

The Preview button u plays back the current Arrangement.

>
During Arranger preview, the main transport Play button L_[&l shows a small “A” icon to indicate it is playing back an arrangement

instead of following the project’s linear timeline, and the active section shows a progress indicator.

Arranger preview can only be started from the Arranger Inspector, not from the Control Bar’s Transport module.

To start preview from a specific section, click a section’s preview button in the Arranger Inspector.

Figure 772. Arranger Preview buttons.
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See also:

“To preview an arrangement” on page 292
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Commit Arrangement to Project button

The Commit Arrangement to Project button renders the arrangement to the project’s timeline and updates track content
accordingly.

If you would like to create linked clips when committing an arrangement, hold down the SHIFT key, then click the Commit

Arrangement to Project button .

See also:
“To commit an arrangement” on page 293

Elapsed / remaining time

The elapsed and remaining time is displayed in H:M:S time format for the current arrangement.
During preview, the first time value increments to show elapsed time. The second time value decrements to show time remaining.

Figure 773. Arranger Inspector.

=1  ARRANGEMENTS

A. Elapsed time B. Remaining time

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Defining sections of your song” on page 283
“Editing sections” on page 286

“Creating arrangements” on page 291
“Navigating by Arranger sections” on page 294

“Exporting arrangements” on page 295
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Defining sections of your song

To use the Arranger track, you must first define time range sections such as Intro, Verse, Chorus, etc. Sections can be of any
duration, but it is common to start/end them at measure boundaries.

Tip: When drawing section in the Arranger timeline, enable Snap to Grid and set the snap resolution to Measure.

Section behaviors

» Sections are presented above the Clips pane, immediately below the time ruler.
» Sections cannot overlap, but do not have to be contiguous.
» Changing the position of a section changes the relative positions of track content within the section, with ripple effect.

» Section position can also be changed without modifying track events.
To add a section

If the Arranger track is not visible, click the Track view View menu and select Arranger Show/Hide, or press A.

If the Arranger Inspector is not visible, click the Show/Hide Arranger button at the top of the Inspector pane.
New sections can be created by any of the following means:
» Draw a range within the Arranger track timeline (below the time ruler).
» Hold down the ALT key to overwrite any downstream sections you draw over.
» Hold down the SHIFT key to move over any downstream sections.
» Double-click a blank area in the Arranger track. The new section duration is inherited from the last clicked section.

» To insert a new section that spans the gap between two existing sections, hold down the ALT key and double-click the gap, or
right-click the gap and select Span Sections.

» Right-click the blank area in the Arranger track timeline and select Insert Section Here to insert a new section at the mouse
position.

» Position the Now Time in a blank area of the Arranger track, then right-click the blank area and select Insert Section at Now
Time.

» A new section appears at the Now Time position.

» If there is space between the Now Time and the next section, the new section will be equal to the size of the previous selected
section, or truncated to fit in the gap.

» If there is no space between the Now Time and the next section, the new section will be equal to the size of the previous
selected section, and downstream sections move to make room. Any selected track events also move.

» If the Now Time position overlaps an existing section, the new section is added at the end.

» Click the Add Section button in the Arranger Inspector.
» The new section duration is inherited from the last clicked section, or defaults to 1 measure.
» If no sections are selected, the new section is added at the end.

» If at least one section is selected, the new section is added at the beginning of the selection, and downstream sections move
to make room. Any selected track events also move.

» Click the Add Section at Now Time button in the Arranger track.

» Make a time selection, for example by selecting a range of track events, then right-click in the time ruler and select Create
Section from Selection. A new Arranger section is created with start/end times defined by the selection.

» You can convert existing text markers to sections. For details, see “Converting markers to sections and vice versa” on page 284.

New sections are given a default name and color, which can be changed by right-clicking the section (see “To rename a section” on
page 286 and “To change the section color” on page 286).
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Figure 774. Adding a section in the Arranger track timeline adds it in the Arranger Inspector as well.
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Converting markers to sections and vice versa

You can automatically create Arranger sections based on existing text markers (see “Creating and using markers” on page 329), and
vice versa.

To convert markers to sections, make a time selection in the time ruler that spans the text markers, then right-click in the time ruler
and select Create Sections from Markers.

The easiest way to use this is to use CTRL+A to select all before invoking this command. Sections are created, beginning at each
text marker location, and ending at the location of the next marker in the timeline. Note that if you have markers beyond the last clip,
you may have to extend your selection to encompass this marker.

The Create Markers from Sections command is similar, except it creates markers from sections. In both cases, any duplicates are
skipped.

Figure 776. Convert markers to Arranger sections.
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To delete a hole between two sections

1. Drag in the time ruler to select the time range that spans the hole you want to delete.

Tip: You can hold ALT and double-click the gap in the Arranger track timeline to create a temporary new sections that spans the gap,
then select the new section.

2. Enable Ripple Edit All (click the Ripple Edit On/Off button , or click the Track view Options menu and select Ripple
Edit All (see “Ripple editing” on page 320).

3. Go to Edit > Delete.
The hole is removed, and track events shift over to fill the gap.

Remember to disable Ripple Edit All if you no longer need to use ripple editing.

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Editing sections” on page 286

“Creating arrangements” on page 291
“Navigating by Arranger sections” on page 294
“Exporting arrangements” on page 295
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Editing sections

Arranger sections can be edited in the Arranger Inspectors Sections list, or in the Arranger track timeline.
If the Arranger track is not visible, click the Track view View menu and select Arranger Show/Hide, or press A.

If the Arranger Inspector is not visible, click the Show/Hide Arranger button at the top of the Inspector pane.

o Note: Arranger sections can also be used by the following commands:

» Edit > Cut Special

» Edit > Copy Special

e Edit > Paste Special

e Edit > Delete Special

* Project > Insert Time/Measures

» Snap to Grid Landmarks (Edit > Preferences > Customization - Snap to Grid)

To rename a section

To rename a section, do one of the following:

» Right-click the section and select Rename.

» Double-click the section in the Arranger Inspector.
» Select the section and press F2.

To change the section color

Right-click the section and select a color on the pop-up menu.

Tip: You can select multiple sections to change their color simultaneously. To select discontiguous sections, hold down the CTRL key
and click the sections you want to select/deselect. To select a range of sections, click the first section, then hold down the SHIFT key
and click the last section (see “To select multiple sections” on page 287).

To resize a section

Drag the left or right section edge.

Abutting sections will move over if extending the section duration.

To overwrite abutting sections, hold down the ALT key while resizing a section.

To move downstream sections when events are selected, hold down the SHIFT key while resizing a section.
To select a section

To select a single section, click the section in the Arranger track timeline or Arranger Inspector Sections list.

Important: By default, clicking an Arranger section also selects underlying track events. Clicking again deselects track events,
while retaining selection of the section. This behavior allows you to easily determine whether or not track events are included in
section edit operations. Note that the selection highlight in the Clips pane indicates selected track events.

To disable automatic selection of track events when selecting sections, click the Track view Options menu and disable Select Events
with Sections.
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To select multiple sections
To select discontiguous sections, hold down the CTRL key and click the sections you want to select/deselect.
To select a range of sections, do one of the following:

» Drag with the right mouse button to lasso select in the Arranger track timeline.

» Click the first section, then hold down the SHIFT key and click the last section.

» Drag in the time ruler to make a selection (this behavior can be enabled/disabled with the Track view Options > Select Sections
with Time Ruler option).

To select all sections

To select all sections, without selecting the underlying track events, right-click any blank area in the Arranger track and select Select
All.

Only the sections themselves are selected. Track events associated with the sections are not selected.
To select all sections and underlying track events

To select all sections along with any underlying track events, right-click any blank area in the Arranger track and select Select All +
Events.

Cakewalk selects all sections and track events across all tracks, within the bounds of the sections.

Excluded tracks (see “Excluding tracks from following arrangements” on page 290) and track events not associated with selected
sections are not affected.

To delete a section

To delete a section, do one of the following:
» Right-click the section and select Delete.
» Click the section, then press the DELETE key.

o Note: When deleting a section, you will also delete any selected track events. Click the section to toggle between selecting only
the section or section+events.

Caution: An arrangement section is an instance of a project section. Deleting a project section will also remove all instances of
that section from all arrangements.

To copy/duplicate a section

» Hold down the CTRL key and drag a section.
» Right-click the section and select Duplicate.
To split a section

Position the Now Time at the location where you want to split the section, then right-click the section and select Split at Now Time.

Note: You can also split clips at section boundaries. To do so, make a selection, then right-click and select Split Clips at
Boundaries.
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To merge multiple sections

Select two or more contiguous sections you want to merge (or drag in the time ruler to make a time selection), then right-click a
selected section and select Merge.

Note: You can use standard Windows CTRL and SHIFT modifiers to select multiple sections.

Tip: When merging multiple sections, the merged section will inherit its name and color from the section you right-click.

To move a section

Drag the section to the desired location (see “Arranger track drag operations” on page 289).

Note: When moving a section, you will also move any selected track events. Click the section to toggle between selecting only
the section and section+track events.

To disable automatic selection of track events when selecting sections, click the Track view Options menu and disable Select
Events with Sections.

To swap two sections

Drag a section onto the middle of another section.

To move a section after another section

Drag the section onto the end of another section.

To copy instead of move, hold down the CTRL key.

To move a section before another section

Drag the section onto the beginning of another section.

To copy instead of move, hold down the CTRL key.

To overwrite an existing section

Hold down the ALT key and drag a section onto another section.

To replace an existing section

Hold down ALT+SHIFT and drag a section onto another section.

To move a section to the middle of another section (and split target section)

Hold down the SHIFT key and drag a section onto the middle of another section.
To copy instead of move, hold down CTRL+SHIFT.

288

Arranging and editing
Arranger track



Arranger track drag operations

You can arrange sections in a variety of ways by using modifier keys. Some operations behave differently depending on whether you
drop at the start, middle, or end on an existing section. The tooltip shows the current operation.

Default

CTRL ALT SHIFT

CTRL+SHIFT ALT+SHIFT

Move to the middle of

Make a copy of Disables ripple for Split destination

Split destination Replace an existing

existing section: Swap section: operation; overwrites if section at drop point section at drop point,  section
Move to end of Drag to middle of dropping into an and move everything  insert copy at drop
existing section: insert existing section: insert existing section over point and move
after existing section copy at beginning or everything else over
Move to beginning of end
existing section: insert Drag to end of existing
before existing section section: insert copy
after existing section
Drag to beginning of
existing section: insert
copy before existing
section
Table 126. Arranger track drag operations
Default CTRL ALT SHIFT CTRL+SHIFT ALT+SHIFT
Move Insert Copy Before Overwrite Split and Insert Split and Insert Copy  Replace
Move Before Insert Copy After
Swap
Move After

Table 127. Arranger track drag operations

Arranger Inspector drag operations

Default

CTRL

ALT

Move directly on top of existing section: Swap
Move above existing section: Insert before with

ripple

Move below existing section: Insert after with

ripple

Make a copy of section

Drag to middle of existing: insert copy at
beginning or end

Drag to end of existing: insert copy at end
Drag to beginning: insert copy at beginning

Disables Ripple for operation (flips replace/
swap behavior)

Table 128. Arranger Inspector drag operations

To cancel a drag operation, press the ESC key.
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Excluding tracks from following arrangements

By default, clicking an Arranger section also selects underlying track events. Clicking again deselects track events, while retaining
selection of the section. This behavior allows you to easily determine whether or not track events are included in section edit
operations. Note that the selection highlight in the Clips pane indicates selected track events.

You can prevent data on individual tracks from being affected when you edit arranger sections. To do so, select Arranger Exclude
in the Track Properties Inspector (see “Properties Inspector - Track Properties” on page 499).

Tip: To exclude all track, press CTRL+A to select all tracks, then select Arranger Exclude in the Track Properties Inspector.

vy |||||||||

Properties
Track 1
v
Methods
(Blastigue ...
(Elastique ...

Automation

Colors

Description

You can also lock individual clips to prevent them from being affected when editing sections. For details, see “Locking Clips” on page
319.

To disable automatic selection of track events when selecting sections, click the Track view Options menu and disable Select
Events with Sections.

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283
“Creating arrangements” on page 291
“Navigating by Arranger sections” on page 294
“Exporting arrangements” on page 295
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Creating arrangements

An arrangement describes the overall structure of the song.

Sections can be sequenced in any order to create arrangements, without affecting project data. The sections don’t have to live on
the project timeline in any specific location or order, because the arrangement determines in which order they are played back.

The Arranger Inspector allows you to create unlimited different arrangements of the current project. Each arrangement can contain
any combination of sections, in any order. All arrangements are saved within the project.

If the Arranger Inspector is not visible, click the Show/Hide Arranger button at the top of the Inspector pane.
To create a new arrangement

1. Click the Arrangements menu and select New.

2. Drag sections from the Sections list down to the Arrangements list. You can also drag sections directly from the Arranger track.
To add a section to the current arrangement
Do one of the following:
» Drag the section(s) from the Sections area or from the Arranger track timeline down to the Arrangements area.
» In the Sections area, select the section(s) you want to add to the current arrangement, then click the Add Selected Sections to
Arrangement button a
To move sections in the Arrangements list, drag them up or down.
To add all sections to the current arrangement

1. Make sure either no sections are selected, or all sections are selected.

2. Click the Add All Sections to Arrangement button E

If one or more sections are selected, only the selected sections will be copied.
To remove a section from the current arrangement

Select the section in the Arrangements list and press the DELETE key.
Right-click the section in the Arrangements list and select Remove.

The Remove command removes the section from the arrangement, but does not delete it from the Sections list or from the
Arranger track timeline.

Tip: To remove all instances of a specific section from the current arrangement, click the section in the Arranger Inspector’s Sections
list. This selects all the instances of the section in the current arrangement. Next, right-click any of the selected instances of the section
in the Arrangements list and select Remove.

To remove all sections from the current arrangement

Right-click an empty area in the Arrangements list and select Remove All Arrangement Sections.
Only the sections themselves are removed. Track events associated with the sections are not affected.

To select all sections in the current arrangement

Right-click an empty area in the Arrangements list and select Select All Arrangement Sections.

Only the sections themselves are selected. Track events associated with the sections are not selected.

Note: Clicking a section in the Arrangements list only sets the Now Time. The sections is not selected in the Arranger track
timeline, and no track events are selected.
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To preview an arrangement

To preview the current arrangement, click the Preview button n in the Arranger Inspector, or press ALT+SPACEBAR. Cakewalk
plays back the Arrangements list instead of the project’s linear timeline.

>
During Arranger preview, the main transport Play button shows a small “A” icon L_[A]

To start preview from a specific section, click a section’s preview button in the Arranger Inspector. Cakewalk plays the current
section to the end, then jumps to the next section until the end of the arrangement is reached.

=] ARRANGEMENTS

Arrangement 2

A. Arrangement preview B. Section preview

To preview only a single section, click the section’s preview button in the Arranger Inspector Sections list.

To start preview from somewhere within a section, position the Now Time where you would like preview to start from, then hold down
the CTRL key and click a preview button, or press CTRL+ALT+SPACEBAR. If the Now Time is within the section, then preview will
start from the Now time. If the Now Time lies outside the preview section time region, preview will start from the beginning of the
section as normal.

To delete an arrangement
1. Select the arrangement you want to delete.

2. Click the Arrangements menu and select Delete.

The arrangement is removed from the menu and all sections in the Arrangements list are removed. No track events or Arranger
track sections are affected.

To rename an arrangement

1. Select the arrangement you want to rename.
2. Click the Arrangements menu and select Rename.
or

Double-click on the name displayed in the closed Arrangements menu.
To duplicate an arrangement

1. Select the arrangement you want to duplicate.
2. Click the Arrangements menu and select Duplicate.
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To commit an arrangement

When you have configured an arrangement the way you like, and you are certain that you do not want to edit it any further, you can
convert it to a linear project.

To commit an arrangement to the project’s timeline, select the arrangement, then click the Commit Arrangement to Project button

The selected arrangement is converted into a linear project, updating track content and section display in the timeline accordingly.
If you would like to create linked clips when committing an arrangement, hold down the SHIFT key, then click the Commit

Arrangement to Project button .

Caution: Rendering an arrangement may potentially remove events from the project, so only use Commit Arrangement to
Project when you no longer need to edit the arrangement. If in doubt, save a backup copy of the project before rendering the
arrangement.

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283
“Editing sections” on page 286

“Navigating by Arranger sections” on page 294

“Exporting arrangements” on page 295
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Navigating by Arranger sections

There are several ways to navigate by sections:
» To locate the Now Time to the start of a section, click the section in the Arranger Inspector.
» To jump to the previous or next section, do one of the following:

» Assign the Go to Previous Section and Go to Next Section key bindings to any unused keyboard shortcuts. For details, see

“Key bindings” on page 971. All the Arranger key bindings are listed in the Global Bindings area in Edit > Preferences >
Customization - Keyboard Shortcuts.

» By default, Arranger sections are treated as markers for navigation purposes:

« Click the Previous Marker b=l or Next Marker =il marker button in the Control Bar’s Markers module.
* Press CTRL+SHIFT+PAGE UP (previous section) or CTRL+SHIFT+PAGE DOWN (next section).

Figure 777. The Markers module.
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Note: By default, the Previous Marker . and Next Marker buttons also jump to the previous/next Arranger sections.
You can change this behavior with the following cakewalk.ini variables:
UseArrSecStartForMarkerNavigation=1 (default 1 [on])

UseArrSecEndForMarkerNavigation=1 (default 0 [off])

For details, see “Initialization files” on page 1141 and “Cakewalk.ini” on page 1142.

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283
“Editing sections” on page 286

“Creating arrangements” on page 291
“Exporting arrangements” on page 295
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Exporting arrangements

You can export one or more arrangements without first having to render it to the timeline.

1. Do one of the following:

» Click the Arrangements menu and select Export as Audio.

» Go to File > Export > Audio to open the Export Audio dialog box.

2. Under Source Category, select Arrangements.

3. Under Source Arrangements, select the arrangement(s) you want to export.

4. Click Export.

Figure 778. Export Audio dialog box.
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See also:
“Preparing audio for distribution” on page 810
“Export Audio dialog” on page 1272

See:

“Arranger track” on page 275

“Arranger track” on page 277

“Arranger Inspector” on page 278

“Defining sections of your song” on page 283
“Editing sections” on page 286

“Creating arrangements” on page 291
“Navigating by Arranger sections” on page 294
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